[Unison-hackers] Compiling Unison on Snow Leopard

Markus Groß mgross at informatik.uni-bremen.de
Wed Dec 9 02:40:18 EST 2009

On 09.12.2009, at 07:16, Alan Schmitt wrote:

> Hello,
> I'm trying to compile Unison on Snow Leopard, and I'm getting the
> following error:
> In file included from /Users/schmitta/godi/lib/ocaml/std-lib/caml/mlvalues.h:22,
>                 from /Users/schmitta/godi/lib/ocaml/std-lib/caml/callback.h:24,
>                 from
> /Users/schmitta/src/unison/trunk/src/uimacnew/MyController.m:15:
> /Users/schmitta/godi/lib/ocaml/std-lib/caml/config.h:125: error:
> conflicting types for ‘uint64’
> /Developer/SDKs/MacOSX10.5.sdk/System/Library/Frameworks/Security.framework/Headers/cssmconfig.h:48:
> error: previous declaration of ‘uint64’ was here
> Have anyone seen this before?

Yes. That happened to me too, when I tried to compile a 64-bit ocaml version.
You have to compile a 32-bit ocaml-version. The mac-gui itself is not x86_64 compatible at the moment, so you can't compile the gui using a 64-bit ocaml version.

I ran into some other error when I tried to compile unison using ocaml 3.11.1. The solution was to use the "release311" branch of ocaml from the ocaml cvs repository.


> Thanks,
> Alan
> _______________________________________________
> Unison-hackers mailing list
> Unison-hackers at lists.seas.upenn.edu
> http://lists.seas.upenn.edu/mailman/listinfo/unison-hackers

More information about the Unison-hackers mailing list