[Unison-hackers] Compiling Unison on Snow Leopard

Markus Groß mgross at informatik.uni-bremen.de
Wed Dec 9 03:03:45 EST 2009

On 09.12.2009, at 08:47, Alan Schmitt wrote:

> On Wed, Dec 9, 2009 at 8:40 AM, Markus Groß
> <mgross at informatik.uni-bremen.de> wrote:
>> Yes. That happened to me too, when I tried to compile a 64-bit ocaml version.
>> You have to compile a 32-bit ocaml-version. The mac-gui itself is not x86_64 compatible at the moment, so you can't compile the gui using a 64-bit ocaml version.
> Could you tell me how to compile a 32-bit ocaml?

./configure -cc "gcc -m32" -as "as -arch i386" -aspp "gcc -m32 -c"

That should do the trick :)

>> I ran into some other error when I tried to compile unison using ocaml 3.11.1. The solution was to use the "release311" branch of ocaml from the ocaml cvs repository.
> Ah, thanks for the info.
> Alan
> _______________________________________________
> Unison-hackers mailing list
> Unison-hackers at lists.seas.upenn.edu
> http://lists.seas.upenn.edu/mailman/listinfo/unison-hackers

More information about the Unison-hackers mailing list